You need to enable JavaScript to run this app.
文档中心
TrafficRoute DNS 套件

TrafficRoute DNS 套件

复制全文
下载 pdf
解析记录管理
解析记录类型
复制全文
下载 pdf
解析记录类型
本文档介绍了火山引擎云解析(DNS)支持的解析记录类型和每种解析记录的添加方法。​
不同类型的解析记录可能会发生冲突。多种类型的解析记录共存时,某些解析记录可能不生效。详细信息参见 避免解析记录冲突或不生效。​
A 记录​
A 记录指定了域名所对应的 IPv4 地址。​
该类型在 RFC 1035 中定义。​
添加 A 记录​
例如,您需要为 example.com 创建以下 A 记录。在该 A 记录中,您指定 example.com 域名对应的 IPv4 地址为 203.0.113.0。​
​
@.example.com. 600 IN A 203.0.113.0​
​
使用控制台添加 A 记录​
您需要使用以下参数添加一条 A 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
A 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 A。​
记录值​
example.com 域名对应的 IPv4 地址,即 203.0.113.0。​
​
使用 OpenAPI 添加 A 记录​
您调用 CreateRecord API 为 example.com 添加一条 A 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "A",​
"Value": "203.0.113.0",​
"ZID": 1234​
}​
​
AAAA 记录​
AAAA 记录指定了域名所对应的 IPv6 地址。​
该类型在 RFC 3596 中定义。​
添加 AAAA 记录​
例如,您需要为 example.com 创建以下 AAAA 记录。在该 AAAA 记录中,您指定 example.com 域名对应的 IPv6 地址为 2001:db8::。​
​
@.example.com. 600 IN AAAA 2001:db8::​
​
使用控制台添加 AAAA 记录​
您需要使用以下参数添加一条 AAAA 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
AAAA 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 AAAA。​
记录值​
example.com 域名对应的 IPv6 地址,即 2001:db8::。​
​
使用 OpenAPI 添加 AAAA 记录​
您调用 CreateRecord API 为 example.com 添加一条 AAAA 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "AAAA",​
"Value": "2001:db8::",​
"ZID": 1234​
}​
​
CNAME 记录​
CNAME 记录将一个域名指向了另一个域名。流量可以通过 CNAME 记录被路由到某个系统或者服务。​
该类型在 RFC 1035 中定义。​
添加 CNAME 记录​
例如,您需要为 example.com 创建以下 CNAME 记录。在该 CNAME 记录中,example.com 域名指向的域名为 service.example.com。​
​
@.example.com. 600 IN CNAME service.example.com. ​
​
使用控制台添加 CNAME 记录​
您需要使用以下参数添加一条 CNAME 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
CNAME 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 CNAME。​
记录值​
example.com 域名指向的域名,即 service.example.com。​
​
使用 OpenAPI 添加 CNAME 记录​
您调用 CreateRecord API 为 example.com 添加一条 CNAME 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "CNAME",​
"Value": "service.example.com",​
"ZID": 1234​
}​
​
MX 记录​
MX 记录指向一个电子邮件服务器。当用户在发送电子邮件时,邮件传输代理(MTA)会根据收件人邮箱地址后缀中的域名(例如 abc@example.com 中的 example.com )发送域名查询请求。根据返回的 MX 记录,邮件传输代理可以获取邮件服务器的域名,并且与邮件服务器建立 SMTP 连接。​
MX 记录的记录值格式为 [域名优先级] [域名]。您可以输入域名优先级以及邮件服务器的域名。例如 10 mail.service.com。数字越小,优先级越高。​
在云解析 DNS 中,域名优先级的取值范围为 1 ~ 99。​
在以下的示例中,mail01.service.com 的优先级高于 mail02.service.com。邮件传输代理会优先与 mail01.service.com 建立 SMTP 连接。只有 mail01.service.com 发送邮件失败时,邮件传输代理才会与 mail02.service.com 建立 SMTP 连接。在这种情况下,mail01.service.com 是主电子邮件服务器,mail02.service.com 是备用电子邮件服务器。​
​
10 mail01.service.com​
20 mail02.service.com​
​
如果您希望实现电子邮件服务器之间的负载均衡,您可以将两个域名的优先级设为相同的值。​
​
10 mail01.service.com​
10 mail02.service.com​
​
该类型在 RFC 1035 中定义。​
添加 MX 记录​
例如,您需要为 example.com 创建以下 MX 记录。在该 MX 记录中,example.com 域名指向的邮件服务器的域名为 mail.example.com。​
​
@.example.com. 600 IN MX 10 mail.example.com. ​
​
使用控制台添加 MX 记录​
您需要使用以下参数添加一条 MX 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
MX 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 MX。​
记录值​
您需要设置为 mail.example.com。​
优先级​
您需要设置为 10。​
​
使用 OpenAPI 添加 MX 记录​
您调用 CreateRecord API 为 example.com 添加一条 MX 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "MX",​
"Value": "10 mail.example.com",​
"ZID": 1234​
}​
​
NS 记录​
指定对域名进行解析的权威 DNS 服务器。​
该类型在 RFC 1035 中定义。​
添加 NS 记录​
例如,您需要为 example.com 创建以下 NS 记录。在该 NS 记录中,example.com 使用域名为 ns1.example.com 的权威 DNS 服务器进行域名解析。​
​
@.example.com. 600 IN NS ns1.example.com. ​
​
使用控制台添加 NS 记录​
您需要使用以下参数添加一条 NS 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
NS 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 NS。​
记录值​
用于解析 example.com 域名的 DNS 服务器,即 ns1.example.com。​
​
使用 OpenAPI 添加 NS 记录​
您调用 CreateRecord API 为 example.com 添加一条 NS 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "NS",​
"Value": "ns1.example.com",​
"ZID": 1234​
}​
​
TXT 记录​
TXT 记录是对域名设置的一个说明。TXT 常用于以下场景:​
  • 验证域名的所有者。例如,您在域名服务商 A 创建了一条 NS 记录,将某个子域名指向域名服务商 B 提供解析。当您在域名服务商 B 配置这个子域名的解析记录时,域名服务商 B 为了确认您是这个子域名的拥有者,会给您提供一条 TXT 记录。您需要在域名服务商 A 创建这条 TXT 记录。这样域名服务商 B 就能验证您的身份了。​
  • 实现基于 SPF 技术的反垃圾邮件功能。例如 v=spf1 a mx ~all。该记录值表示只有域名下的 A 记录和 MX 记录所配置的 IP 地址才有权限使用该域名发送电子邮件。​
该类型在 RFC 1035 中定义。​
在云解析 DNS 中,TXT 记录的记录值长度不能超过 512 个字符。而且,记录值仅支持除双引号(")和单引号(')外的 ASCII 字符。​
添加 TXT 记录​
例如,您需要为 example.com 创建以下 TXT 记录。该 TXT 记录规定只有域名下的 A 记录和 MX 记录所配置的 IP 地址才有权限使用该域名发送电子邮件。​
​
@.example.com. 600 IN TXT v=spf1 a mx ~all ​
​
使用控制台添加 TXT 记录​
您需要使用以下参数添加一条 TXT 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
TXT 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 TXT。​
记录值​
您需要设置为 v=spf1 a mx ~all。​
​
使用 OpenAPI 添加 TXT 记录​
您调用 CreateRecord API 为 example.com 添加一条 TXT 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "TXT",​
"Value": "v=spf1 a mx ~all",​
"ZID": 1234​
}​
​
SRV 记录​
SRV 记录指示特定服务使用的特定服务器。比如对于 Microsoft 的活动目录,您可以通过 SRV 记录指定域控制器,使得相应的活动目录用户能正常操作。​
SRV 记录的记录值格式为 [优先级] [权重] [端口] [域名]。例如,0 3 3000 sipserver.example.com。​
该类型在 RFC 2782 中定义。​
添加 SRV 记录​
您需要为 example.com 创建以下 SRV 记录。该 SRV 记录指定域控制器。​
​
@.example.com. 600 IN SRV 0 3 3000 sipserver.example.com. ​
​
使用控制台添加 SRV 记录​
您需要使用以下参数添加一条 SRV 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
SRV 记录对应的域名,即 @.example.com。​
记录类型​
您需要设置为 SRV。​
记录值​
您需要设置为 0 3 3000 sipserver.example.com。​
​
使用 OpenAPI 添加 SRV 记录​
您调用 CreateRecord API 为 example.com 添加一条 SRV 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "SRV",​
"Value": "0 3 3000 sipserver.example.com",​
"ZID": 1234​
}​
​
CAA 记录​
CAA 记录用于指定允许为域名颁发证书的证书颁发机构 (CA)。​
CAA 记录的记录值格式为:[flag] [tag] [value]。该格式包含以下参数:​
  • [flag]:表示 CA 机构处理本记录值的方式。一般情况下该参数值是 0。0 表示如果 CA 机构无法识别本记录值中 tag 参数值的含义,CA 机构会忽略本记录值。关于更多 [flag] 参数的含义,参见 RFC 6844 中定义。在云解析 DNS 中,[flag] 参数的取值范围是 0 ~ 255。​
  • [tag]:该参数有以下取值:​
  • issue:表示一个 CA 机构。只有该 CA 机构才能为指定域名颁发证书。​
  • issuewild:表示一个 CA 机构。只有该 CA 机构才能为指定域名颁发泛域名证书。​
  • iodef:表示一个 URL。如果接收到证书申请的 CA 机构不在您指定的 CA 机构列表中,该 CA 机构可以将此违规的申请记录发送到该 URL。​
  • [value]:如果 [tag] 参数是 issue 或者 issuewild,该参数表示指定的 CA 机构。如果 [tag] 参数是 iodef,该参数表示指定的 URL。​
该类型在 RFC 6844 中定义。​
添加 CAA 记录​
例如,您需要为 example.com 创建以下 CAA 记录。在该 CAA 记录中,您为 example.com 指定了 DigiCert 和 Let’s Encrypt 两个 CA 机构。同时,您指定了一个 iodef 记录。​
​
@.example.com. 600 IN CAA 0 issue "letsencrypt.org" ​
@.example.com. 600 IN CAA 0 issue "digicert.com" ​
@.example.com. 600 IN CAA 0 iodef "mailto:admin@dns-example.com" ​
​
您为 example.com 申请证书时:​
  • 如果您向 DigiCert 或 Let’s Encrypt 申请证书,DigiCert 或 Let’s Encrypt 会颁发证书。​
  • 如果您向 GeoTrust 申请证书,GeoTrust 不会颁发证书。同时,GeoTrust 可以将此违规的申请记录发送到 admin@dns-example.com 邮箱。​
使用控制台添加 CAA 记录​
您需要使用以下参数添加三条 CAA 记录。每个记录值是一条记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
CAA 记录对应的域名,例如 example.com。​
记录类型​
您需要设置为 CAA。​
线路​
您需要设置为 默认。否则,部分 CA 机构可能会认证失败。​
记录值​
CAA 记录的属性,包括 issue、issuewild 或 iodef。每个记录值包含一个属性。您可以添加一条或多个记录值。记录值中的域名两边需要添加双引号("")。您可以按照下面的截图设置记录值。​
​Image​​
​
使用 OpenAPI 添加 CAA 记录​
您调用 CreateRecord API 为 example.com 添加三条 CAA 记录。​
添加记录值:0 issue "letsencrypt.org"​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "CAA",​
"Value": "0 issue \"letsencrypt.org\"",​
"ZID": 1234​
}​
​
添加记录值:0 issue "digicert.com"​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "CAA",​
"Value": "0 issue \"digicert.com\"",​
"ZID": 1234​
}​
​
添加记录值:0 iodef "mailto:admin@dns-example.com"​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "@",​
"Line": "default",​
"TTL": 600,​
"Type": "CAA",​
"Value": "0 iodef \"mailto:admin@dns-example.com\"",​
"ZID": 1234​
}​
​
PTR 记录​
PTR 记录将 IP 地址反向解析为域名。PTR 记录可用于反向 DNS 查询,即通过 IP 地址查找域名。反向 DNS 查询一般有以下应用场景:​
  • 反垃圾邮件:当用户在发送电子邮件时,邮件传输代理(MTA)会根据收件人邮箱地址后缀中的域名(例如 abc@example.com 中的 example.com )发送域名查询请求,获取域名所对应的 IP 地址。同时,一些电子邮件服务商的邮件传输代理(MTA)会对发件人邮箱的 IP 地址进行反向 DNS 查询,验证发件人邮箱的域名与反向 DNS 查询的结果是否匹配。如果不匹配或邮箱没有 PTR 记录,则验证失败,邮件不会被成功发送。​
  • 基于日志的问题排查:日志中一般记录 IP 地址而不是域名。反向 DNS 查询可以通过日志中的 IP 地址找到对应的域名,方便问题排查。​
该类型在 RFC 1035 和 RFC 8501 中定义。​
说明​
云解析 DNS 仅支持 IPv4 地址的 PTR 记录,暂不支持 IPv6 地址的 PTR 记录。​
添加 PTR 记录​
参见 购买 PTR 记录。​
URL 记录​
URL 记录将一个 URL 重定向到另一个 URL。例如,URL 记录可以将 http://example.com 定向到 http://doc.example.com。URL 记录是云解析 DNS 提供的一种特殊的记录类型,不在任何 RFC 中定义。​
注意​
云解析 DNS 不对 URL 记录提供 SLA 保障或 DNS 安全保护。如果您的 URL 记录不可用,您可以通过 CNAME 记录、A 记录或自建 URL 转发服务等方式把原 URL 重定向到目标 URL。​
您为您的域名添加 URL 转发记录时,云解析 DNS 会自动为您的域名添加一条 A 记录,而该 A 记录指向的 IP 地址是云解析 DNS 的 URL 转发服务器的 IP 地址。该转发服务器把访问原 URL 的 HTTP 请求重定向到目标 URL。​
用户访问您的 URL 时,会首先通过 DNS 查询请求获取云解析 DNS 的 URL 转发服务器地址。接下来,用户向 URL 转发服务器发送 HTTP 请求。云解析 DNS 支持显性 URL 记录和隐性 URL 记录。​
  • 如果 URL 记录的类型是 显性 URL 记录:访问您的 URL 的 HTTP 请求会通过 301 重定向或 302 重定向从原 URL 被跳转到目标 URL。​
  • 如果 URL 记录的类型是 隐性 URL 记录:转发服务器返回一个 index.html 文件。该文件包含一个 <iframe> 元素,且 src 是目标 URL。这样,目标 URL 的页面会被嵌套到<iframe> 元素中。因此,在隐性 URL 转发中,访问您的域名的 HTTP 请求不会被跳转。​
使用限制​
在云解析 DNS 中,URL 记录有以下限制:​
  • 原 URL 和目标 URL 所对应的域名都需要完成工信部 ICP 备案。​
  • 记录值中 URL 的长度不能超过 512 个字符。​
  • URL 转发时记录值不能为IP地址,必须为域名或URL地址。​
  • URL 记录不支持泛域名。​
  • URL 记录的线路只能是 默认。​
  • 每个火山引擎账号能创建的 URL 记录数量存在限制。参见 功能版本规格。​
  • 一个记录集最多只能包含一条启用的 URL 记录。​
  • 原 URL 仅支持 HTTP 协议;目标 URL 支持 HTTP 和 HTTPS 协议。​
添加 URL 记录​
例如,您需要为 example.com 添加一条 URL 记录。该 URL 记录使用显性 URL 转发和 301 重定向将 http://example.com 定向到 http://doc.example.com。​
使用控制台添加 URL 记录​
您需要使用以下参数添加一条 URL 记录。参见 添加解析记录了解如何在云解析 DNS 的控制台添加解析记录。​
​
参数​
描述​
域名​
URL 记录中原 URL 的域名,即 @.example.com。​
记录类型​
URL 记录的类型。​
  • 显性 URL:访问您的 URL 的 HTTP 请求会通过 301 或 302 重定向从原 URL 被跳转到目标 URL。​
  • 隐性 URL:转发服务器返回一个 index.html 文件。该文件包含一个 <iframe> 元素,且<iframe> 元素的 src 是目标 URL。这样,目标 URL 的页面会被嵌套到 <iframe> 元素中。在隐性 URL 转发中,访问您的域名的 HTTP 请求不会被跳转。​
在该示例中,您需要设置为 显性 URL。​
记录值​
URL 记录的目标 URL。目标 URL 可以包含国际化域名(IDN)。目标 URL 可以包含端口号。​
  • 对于显性 URL,您需要先选择 301 重定向或 302 重定向,然后输入目标 URL。​
  • 301 重定向:表示请求的资源已经被永久地移动到了新的 URL。​
  • 302 重定向:表示请求的资源暂时被移动到了另一个 URL。​
  • 对于隐性 URL,您可以直接输入目标 URL。​
在该示例中,您需要选择 301 重定向,把记录值设置为 http://doc.example.com。​
​
使用 OpenAPI 添加 URL 记录​
您调用 CreateRecord API 为 example.com 添加一条 URL 记录。​
​
POST https://dns.volcengineapi.com?Version=2018-08-01&Action=CreateRecord​
{​
"Host": "test",​
"Line": "default",​
"TTL": 600,​
"Type": "URL",​
"Value": "REDIRECT_URL_301 http://doc.example.com",​
"ZID": 1234​
}​
​
OpenAPI 参数说明​
您调用 CreateRecord API 时,向 Value 参数传入的记录值格式是 [转发类型] [URL],例如 REDIRECT_URL_301 http://doc.example.com。[转发类型] 可以是以下值:​
  • REDIRECT_URL_301:显性 URL 转发,301 重定向。​
  • REDIRECT_URL_302:显性 URL 转发,302 重定向。​
  • FORWARD_URL:隐性 URL 转发。​
​
最近更新时间:2026.08.04 10:18:09
这个页面对您有帮助吗?
有用
有用
无用
无用