You need to enable JavaScript to run this app.
Volcengine Kubernetes Engine

Volcengine Kubernetes Engine

Copy page
Download PDF
Security announcements
Kubernetes security vulnerability advisory (CVE-2024-10220)
Copy page
Download PDF
Kubernetes security vulnerability advisory (CVE-2024-10220)
The security vulnerability CVE-2024-10220 was disclosed by the Kubernetes community. Attackers can exploit this vulnerability through the gitRepo volume to pull a malicious git repository, which may result in arbitrary code execution, unauthorized access to the host, or execution of binary programs. For details, refer to CVE-2024-10220: Arbitrary command execution through gitRepo volume.​
Vulnerability level​
The CVE-2024-10220 vulnerability is assessed as a high risk vulnerability, with a CVSS score of 8.1.​
Scope of impact​
  • Affected kubelet versions: kubelet <= v1.28.11​
  • Node Kubernetes version < v1.28.15-vke.18​
  • Node Kubernetes version < v1.26.15-vke.25​
  • Node Kubernetes version < v1.24.17-vke.37​
Vulnerability impact​
When the VKE version in use falls within the affected range, if an attacker has permission to create Pods and the gitRepo volume is available, the attacker can pull a malicious git repository, resulting in arbitrary code execution. For more details, refer to K8s gitRepo volume arbitrary code execution (CVE-2024-10220).​
Preventive measures​
Use admission controllers to detect and block Pods that use gitRepo volumes. You can select admission controllers and policies such as Kyverno, OPA-gatekeeper, or ValidatingAdmissionPolicy (Kubernetes v1.30 GA) to prohibit workloads from using the GitRepo volume. Below is a ClusterPolicy that uses Kyverno to disable the GitRepo volume for your reference.​
​
apiVersion: kyverno.io/v1​
kind: ClusterPolicy​
metadata:​
name: disallow-gitrepo​
spec:​
validationFailureAction: Enforce​
background: true​
rules:​
- name: check-for-gitrepo-volume​
match:​
any:​
- resources:​
kinds:​
- Pod​
validate:​
message: >-​
GitRepo volumes are forbidden. The fields spec.volumes[*].gitRepo must not be set.​
pattern:​
spec:​
=(volumes):​
- X(gitRepo): "null"​
​
Remediation​
  • Newly created VKE clusters are not affected by this vulnerability.​
  • For VKE cluster nodes within the affected scope, please upgrade the cluster to the latest patch version.​
  • For users who are unable to use the cluster upgrade feature, please submit a ticket to obtain technical support, or adopt preventive measures.​
Last updated: 2026.07.15 15:51:29